Resource icon

Mark Threads As "Solved" 2.0.1

No permission to download
My time is very limited these days, with my full time job. I have marked this mod as re-usable code, if any other coder wishes to continue work on it. I may still try to support this mod as time permits.



If you use this modification, please >> Mark As Installed, and consider Nominate for MOTM and Support Developer <<



What is this!?
This modification will allow you & your members (based on usergroup permissions) to mark a thread as "Solved". It will add the prefix "[SOLVED]" to the thread title, and if set in the admincp - it will also close the thread.

Current Version
2.0.1.

Features flagged for future version(s):
  • Thread starter can choose to solve a thread, and input the username of who solved it - that user would receive rep. points. (admin-configurable amount of rep. points)
  • Given the above - include count of threads a user has solved in postbit & profile
  • Option to move the thread to a specific forum when a thread is "Solved"
  • Possibly figure out a way to automate everything on install - so there are no template edits.
And anything else that is suggested

Will this work on x.x.x ??
Unless otherwise stated, this will work on all 4.0.x versions. This will not work on 3.x.

Sounds cool. How do I install?
  1. Extract the zip, you should have the following directories/files:


    Code:
    /
    |_ install.html
    |_ product-solvedthread.xml

    /upload/
    |_ solved.php

    /upload/images/
    /buttons/
    |_ marksolved.gif

    /upload/includes/
    /xml/
    |_ bitfield_solvedthread.xml
  2. Upload: (in the below instructions 'yourforum' would be where you have vBulletin installed)
    • /upload/solved.php to /yourforum/solved.php
    • /upload/images/buttons/marksolved.gif to /yourforum/images/buttons/marksolved.gif (upload to each style folder, if you have more than one style)
    • /upload/includes/xml/bitfield_solvedthread.xml to /yourforum/includes/xml/bitfield_solvedthread.xml
  3. Import the product, product-solvedthreads.xml by going to: AdminCP -> Plugins & Products -> Manage Products -> [Add/Import Product]
  4. Make the following template edits to all of your installed styles:

    SHOWTHREAD

    Find:

    HTML Code:
    <vb:if condition="$show['addpoll']">
    <li><a href="poll.php?{vb:raw session.sessionurl}do=newpoll&amp;t={vb:raw threadid}">{vb:rawphrase add_a_poll_to_this_thread}&hellip;</a></li>
    </vb:if>
    Add after:

    HTML Code:
    <vb:if condition="$show['solvedthread']">
    <li><a href="solved.php?{vb:raw session.sessionurl}do=marksolved&amp;t={vb:raw threadid}">{vb:rawphrase solvedthread_marksolved}&hellip;</a></li>
    <vb:else />
    <vb:if condition="$show['solvedthread_unsolve']">
    <li><a href="solved.php?{vb:raw session.sessionurl}do=markunsolved&amp;t={vb:raw threadid}">{vb:rawphrase solvedthread_markunsolved}&hellip;</a></li>
    </vb:if>
    </vb:if>
  5. Set options in AdminCP > Settings > Options > Solved Threads
  6. Edit Solved Threads Permissions > Can Mark Threads as Solved for each usergroup.
  7. To setup the forums it can be used in, follow the instructions in this post.
Upgrade
  1. Re-import the product, product-solvedthreads.xml, with "Allow Overwrite" set to yes
  2. Upload the files/folders in the "upload" folder, allowing it to overwrite the old files.
That's it! Enjoy!

Changelog
2.0.1 - July 30, 2010
  • Changes to solved.php, to check for errors while saving thread, changed how threadinfo is pulled.
  • Changes to bitfield_solvedthread.xml, removed the "install" attribute, doesn't seem to work anyway.
  • Changes to product-solvedthread.xml, install process. Gave the install a small delay between rebuilding prefix datastore (after adding prefixset), and creating prefix.
  • Changes to product-solvedthread.xml, plugin. Removed check for can_use_prefix function, as vB 3.8 + includes it, and this mod is for 4.0

2.0.0 - February 3, 2010
- Updated to vBulletin 4

1.1.2 - January 15, 2010
- Updated the product file, permissions, and phrases. This should, hopefully, resolve the blank page problems, along with the permission not showing up for usergroups.

1.1.1 - July 21, 2009
- Updated the product plugins and phrases, this should solve the blank page problem, and the problem of the option not showing in Admincp for ug permissions.

1.1.0 - April 14, 2009
  • Small updates to xml file, no version # change. If it works for you, no need to do anything.
  • If you have problems uninstalling, please see this post.

1.1.0 - April 12, 2009
  • Updated for 3.7 & 3.8
  • Now uses the built-in Thread Prefix system
  • Instead of 'excluding' forums, since using the Thread Prefix system, you can choose which forums this will be shown in.

1.0.1 - July 12, 2007
  • Added the ability to unsolve a thread.
  • Added the ability to exclude this in certain forums
  • Added the ability to change the prefix in that acp

1.0.0 - June 8, 2007
- Initial release.


If you use this modification, please >> Mark As Installed, and consider Nominate for MOTM and Support Developer <<



NOTE: This mod is marked "unsupported", but I'll try my best (as time permits) to help those who have marked as installed.
Author
putr
Downloads
0
Views
39
First release
Last update
Rating
0.00 star(s) 0 ratings

More resources from putr